Compilation environment fixes to make make install work correctly.
[crypto.git] / lib / silcacc / tests / Makefile.am
index b431654f57824b6ea70870ca8dae529b356a7a03..72827b0e9494d006d7437817e432daf2e38510bc 100644 (file)
@@ -3,7 +3,7 @@
 #
 #  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2007 Pekka Riikonen
+#  Copyright (C) 2007, 2008 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
 
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
-bin_PROGRAMS = test_softacc
-
-test_softacc_SOURCES = test_softacc.c
+check_PROGRAMS = test_softacc                  \
+               test_softacc_cipher             \
+               test_softacc_cipher2
 
 LIBS = $(SILC_COMMON_LIBS)
-LDADD = -L.. -L../.. -lsilc -lsilcacc
+LDADD = -L.. -L../.. -lsct
 
 include $(top_srcdir)/Makefile.defines.in