Compilation environment fixes to make make install work correctly.
[crypto.git] / lib / silccrypt / tests / Makefile.am
index 1fd793a91f789c3565edf8b51222e85d8782be1e..8d79e2027a1a5ac667161297e027a1c3ae2266f2 100644 (file)
@@ -3,7 +3,7 @@
 #
 #  Author: Pekka Riikonen <priikone@silcnet.org>
 #
-#  Copyright (C) 2002 - 2003 Pekka Riikonen
+#  Copyright (C) 2002 - 2003, 2008 Pekka Riikonen
 #
 #  This program is free software; you can redistribute it and/or modify
 #  it under the terms of the GNU General Public License as published by
 
 AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
 
-bin_PROGRAMS =         test_sha1       \
+check_PROGRAMS = test_sha1     \
+               test_sha256     \
                test_md5        \
                test_hmacsha1   \
+               test_hmacsha256 \
                test_hmacmd5    \
                test_aes        \
                test_twofish    \
-               test_silcpkcs
-
-test_sha1_SOURCES = test_sha1.c
-test_md5_SOURCES = test_md5.c
-test_hmacsha1_SOURCES = test_hmacsha1.c
-test_hmacmd5_SOURCES = test_hmacmd5.c
-
-test_aes_SOURCES = test_aes.c
-test_twofish_SOURCES = test_aes.c
-
-test_silcpkcs_SOURCES = test_silcpkcs.c
+               test_cast5      \
+               test_des        \
+               test_silcpkcs   \
+               test_dsa        \
+               test_hash       \
+               test_cipher
 
 LIBS = $(SILC_COMMON_LIBS)
-LDADD = -L.. -L../.. -lsilc
+LDADD = -L.. -L../.. -lsct
 
 include $(top_srcdir)/Makefile.defines.in